SPAM olarak kabul edilen şey nedir?
Hangi kullanıcılar ve posta sunucuları spam e-posta olarak nitelendirilir?
RealSender ile olan deneyimimizden yola çıkarak ,
gelen kutusuna teslimatı etkileyebilecek temel noktaları özetlemeye çalıştık.
- Kullanıcıların
mesajlara vereceği tepkiler, alıcılar tarafından beklenilen/istenilen tepkiler olmalıdır.
- Teknik noktalar:
E-posta mesajlarının kabul edilmesi için temel ayarlar gereklidir. - IP adresi ve IP sınıfı itibarı
- doğru SMTP sunucu kurulumu
- Doğru e-posta kimlik doğrulaması
- SPAMASSASSIN kontrolü
- Deneyin ve ne olacağını görün.
Bir e-postanın spam olarak sınıflandırılıp sınıflandırılmadığını anlamanın tek kesin yolu...
onu göndermek ve karşı tarafta nasıl göründüğüne bakmaktır.
Mesajlar alıcıları tarafından beklenmiyorsa/istenmiyorsa,
diğer noktaları değerlendirmenin hiçbir faydası yoktur
KULLANICI tepkileri
Gönderen, alıcının yerine kendini koymalı ve e-posta mesajının nasıl ele alınacağını anlamaya çalışmalıdır.
Kullanıcı şikayetleri, tüm SMTP sunucusunun veya alan adının kara listeye alınmasına yol açabilir ve bu da gelecekteki tüm mesajların teslimatını etkileyebilir.
- Kullanıcılar genellikle* gelen kutularını yönetebilirler: her kullanıcının spam olarak değerlendirdiği şey "spam"dir.
* = birçok ücretsiz e-posta sağlayıcısı "dahili reklamlarından" vazgeçme seçeneği sunmaz. - Kullanıcı, Gmail'de "Spam Bildir" düğmesine
veya Outlook/Hotmail'de "Önemsiz" düğmesine tıklayarak tercihini belirtir. - Modern e-posta sunucularının spam filtreleri tamamen kullanıcı şikayetlerine bağlıdır; "Spam Olarak Bildir" seçeneğine belirli sayıda tıklandıktan sonra,
benzer içerikteki tüm mesajlar doğrudan spam klasörüne gönderilir.
E-posta mesajlarının kabul edilmesi için temel teknik ayarlar gereklidir.
IP adresi ve IP sınıfı itibarı
- SMTP sunucu IP adreslerinin kara listeye alınmasıyla ilgili birçok aracı Google'da "kara liste kontrolü" şeklinde aratarak bulabilirsiniz
- SMTP sunucu IP sınıfı itibarı hakkında daha fazla bilgi için blog yazımıza göz atın: SMTP IP İTİBARI ÖNEMLİDİR
- Eğer mesajlar kişisel bir bilgisayardan gönderiliyorsa, internet bağlantısının genel IP adresinin itibarı da kontrol edilmelidir
(bazı SMTP sunucu sağlayıcıları internet bağlantısının IP adresini maskeler, böylece alıcının sistemi yalnızca kendi IP adresini görür).
doğru SMTP sunucu kurulumu
- Ters DNS,
posta sunucunuzun IP adresinin, posta göndermek için kullandığınız alan adına işaret ettiğinden emin olmak anlamına gelir. - E-postaları yönlendiren ve teslim eden uygulama olan posta aktarım aracısı,
IETF tarafından yayınlanan en son RFC'ye uygun şekilde yapılandırılmalıdır
(örneğin: Postfix'i RFC Uyumlu Hale Getirme).
Doğru e-posta kimlik doğrulaması
E-postalarınızın ve alan adınızın birbirine ait olduğunu kanıtlamak için SPF ve DKIM gibi e-posta kimlik doğrulama yöntemlerini kullanın.
Bunun güzel bir yan etkisi de, e-posta alan adınızın taklit edilmesini önlemeye yardımcı olmanızdır.
- SPF, e-posta alıcılarının, gönderenin DNS TXT kayıtlarında yayınladığı bilgilere dayanarak gönderenin giden MTA'sının IP adresini değerlendirerek, gönderenin mesaj başlığındaki alan adlarını kullanma yetkisine sahip olup olmadığını belirlemesine olanak tanıyan, yol tabanlı bir e-posta kimlik doğrulama protokolüdür. SPF, IETF RFC 4408'de tanımlanmıştır.
- DKIM, göndericinin giden e-postaları alıcı tarafından doğrulanabilecek şekilde imzalamak için açık anahtarlı şifrelemeyi kullanmasını sağlayan bir e-posta kimlik doğrulama protokolüdür. DKIM, IETF RFC 4871'de tanımlanmıştır. DKIM standardı, Gmail ve diğer büyük şirketler tarafından internet postalarından kimlik avı ve sahtekarlığı tamamen ortadan kaldırmak için benimsenmiştir.
- DMARC, e-posta kimlik doğrulaması için yerleşik SPF ve DKIM standartlarına dayanır. Hedef posta sunucuları, gönderenin "dmarc politikasına" göre kimliği doğrulanmamış postalar üzerinde işlem yapar ve sonucu gönderene bildirir. DMARC, İnternet Mühendisliği Görev Gücü'nün yayınladığı RFC 7489 belgesinde tanımlanmıştır.
SPAMASSASSIN kontrolü
- SpamAssassin, e-posta spam filtrelemesi için kullanılan sunucu tarafı bir yazılımdır. Çeşitli spam tespit teknikleri kullanır.
Her testin bir puan değeri vardır. Puanlar pozitif veya negatif olabilir; pozitif değerler "spam", negatif değerler ise "ham" (spam olmayan) anlamına gelir.
Alıcı için varsayılan puan eşiği "5.0"dır. Bir e-postanın puanı eşikten yüksekse, spam olarak işaretlenir.
O kadar yaygın olarak kullanılır ki, e-posta mesajları göndermeden önce puan kontrolünün zorunlu olarak yapılması gerektiği düşünülebilir. - SpamAssassin puanınızı kontrol etmenize yardımcı olabilecek iki çevrimiçi araç şunlardır: spam değil Ve posta test cihazı
- Mesajı verilen e-posta adresine göndermeniz gerekiyor
- Birkaç saniye sonra "raporunuzu görüntüleyin" veya "sonrasında puanınızı kontrol edin" düğmelerine
Bir e-postanın spam olarak sınıflandırılıp sınıflandırılmadığını anlamanın tek kesin yolu...
onu göndermek ve karşı tarafta nasıl göründüğüne bakmaktır.
Deneyin ve neler olacağını görün
- Eğer reddedilen bir mesaj alırsanız, bu çok yardımcı olabilir çünkü son birkaç satır genellikle reddedilmeye neden olan sorunu açıklar.
Açıklama anlaşılmazsa, "Test mesajı" konu ve içeriğiyle bir mesaj göndermeyi deneyin ve kabul edilip edilmediğini kontrol edin.
Bu durumda, spam filtresini hangi bölümün etkinleştirdiğini belirleyene kadar aynı mesajı birkaç kez gönderip içeriği kademeli olarak azaltmalısınız. - Ayrıntılı bir gönderim günlüğüne sahip olmak, mesajların kabul edilip edilmediğini veya reddedilip reddedilmediğini doğrulamanıza yardımcı olabilir;
günlükte bulunan bilgilere - Bazı (nadir) durumlarda bir tür "beyaz liste" gereklidir.
Bazı spam sistemleri, kullanıcıların aldıkları mesajlarla ne yaptıklarından öğrenir.
Eğer alıcı, aldığı e-postayı bir kez "spam DEĞİL" olarak işaretlerse,
sistem bunların geçerli mesajlar olduğunu öğrenir ve bunları "Önemsiz" klasörü yerine "Gelen Kutusu" klasörüne teslim etmeye başlar.
Alternatif olarak, gönderenin alıcının adres defterinde olması veya daha önce onunla e-posta alışverişinde bulunmuş olması gerekir.